2024-04-15 08:55 (월)
OpenSSL, 14개 다중 취약점 발견…보안업데이트 권고
상태바
OpenSSL, 14개 다중 취약점 발견…보안업데이트 권고
  • 길민권
  • 승인 2015.03.24 03:50
이 기사를 공유합니다

암호화된 데이터 복호화 및 서비스 거부 취약점 등 14개 취약점 발견
취약한 OpenSSL 버전을 사용하는 서버와 클라이언트 사이에서 공격자가 암호화된 데이터를 복호화할 수 있는 취약점이 발견됐다. 이외 서비스 거부 취약점 등 14개의 취약점이 발견돼 이를 보완한 보안 패치가 발표됐다. 이에 이용자들은 신속한 보안업데이트를 적용해야 안전할 수 있다.
 
이번에 발견된 취약점은 다음과 같다.
-NULL 포인터 역참조에 의한 서비스 거부 공격에 악용될 수 있는 취약점 (CVE-2015-0291)
-OpenSSL RSA 암호화 키를 512비트로 다운그레이드 시키는 취약점(FREAK, CVE-2015-0204)
-멀티 블록 포인터 손상에 의한 서비스 거부 공격에 악용될 수 있는 취약점(CVE-2015-0290)
-DTLSv1_listen 함수에서 잘못된 메모리 접근으로 인해 서비스 거부 공격에 악용될 수 있는 취약점 (CVE-2015-0207)
-ASN1_TYPE_cmp 함수에서 잘못된 메모리 접근으로 인해 서비스 거부 공격에 악용될 수 있는 취약점 (CVE-2015-0286)
-PSS 파라미터에서 잘못된 메모리 접근으로 인해 서비스 거부 공격에 악용될 수 있는 취약점(CVE-2015-0208)
-메모리 재사용 시 발생할 수 있는 메모리 손상 취약점(CVE-2015-0287)
-PKCS#7 NULL 포인터 역참조에 의한 데이터의 조작이 가능한 취약점 (CVE-2015-0289)
-base64로 인코딩된 데이터 처리 중 발생하는 메모리 충돌 취약점(CVE-2015-0292)
-SSLv2 서버를 대상으로 한 서비스 거부 취약점(CVE-2015-0293)
-ClientKeyExchange 전송 중 서비스 거부 공격에 악용될 수 있는 취약점 (CVE-2015-1787)
-난수 생성을 위해 핸드쉐이크 메시지 처리 중 서비스 거부 공격이 발생할 수 있는 취약점 (CVE-2015-0285)
-d2i_ECPrivateKey 함수 에러로 인해 발생하는 use-after-free 취약점(CVE-2015-0209)
-X509_to_X509_REQ 함수 NULL 포인터 역참조에 의한 서비스 거부 공격에 악용될 수 있는 취약점(CVE-2015-0288)
 
해당 취약점에 영향 받는 버전은 △OpenSSL 0.9.8 대 버전 △OpenSSL 1.0.0 대 버전 △OpenSSL 1.0.1 대 버전 △OpenSSL 1.0.2 대 버전 등이다.
 
해당 취약점에 영향 받는 버전의 사용자는 아래 버전으로 업데이트해야 한다.
-OpenSSL 0.9.8 사용자: 0.9.8zf로 업데이트
-OpenSSL 1.0.0 사용자: 1.0.0r로 업데이트
-OpenSSL 1.0.1 사용자: 1.0.1m로 업데이트
-OpenSSL 1.0.2 사용자: 1.0.2a로 업데이트
 
<참고사이트>
-https://www.openssl.org/news/secadv_20150319.txt
-https://www.openssl.org/
 
★정보보안 대표 미디어 데일리시큐!★
 
<데일리시큐 길민권 기자> mkgil@dailysecu.com
■ 보안 사건사고 제보 하기

▷ 이메일 : mkgil@dailysecu.com

▷ 제보 내용 : 보안 관련 어떤 내용이든 제보를 기다립니다!

▷ 광고문의 : jywoo@dailysecu.com

★정보보안 대표 미디어 데일리시큐 / Dailysecu, Korea's leading security media!★