2019-12-12 17:35 (목)
PHP 다수 취약점 보안 패치 발표…최신 버전으로 업데이트해야
상태바
PHP 다수 취약점 보안 패치 발표…최신 버전으로 업데이트해야
  • 길민권
  • 승인 2019.09.16 16:18
이 기사를 공유합니다

PHP 그룹은 다수의 보안 취약점을 해결한 보안 업데이트를 최근 발표했다. 이번 취약점으로 공격자는 임의코드 실행 등 피해를 발생시킬 수 있어 해당 제품을 사용하는 이용자들은 최신 버전으로 업데이트해야 안전할 수 있다고 한국인터넷진흥원(KISA)이 권고했다.

이번에 패치된 취약점 내용은 아래와 같다.

-PHP의 특정 함수의 입력값 검증 미흡으로 정보노출 및 use-after-free 취약점 발생(CVE-2019-13224)

-PHP의 특정 함수에서 파일 검증 미흡으로 발생하는 정보노출 취약점(CVE-2019-11040 외 다중 취약점)

-PHP의 특정 함수에서 MIME 헤더를 파싱 시 오버플로우 발생으로 정보노출 가능 취약점(CVE-2019-11039)

-PHP의 특정 함수를 통해 메모리에 저장된 값을 읽고 쓰기가 가능한 취약점(CVE-2019-9025)

-PHP의 특정 함수에서 입력값 검증이 미흡하여 임의의 메모리 주소에 접근 가능한 취약점(CVE-2019-9020)

취약점에 영향을 받는 제품은 △PHP 7.1 ~ 7.1.32 이전 버전 △PHP 7.2 ~ 7.2.22 이전 버전 △PHP 7.3 ~ 7.3.9 이전 버전 등이다. 사용자들은 신속한 버전 업데이트를 적용해 사용해야 한다.

<참고사이트>

-https://www.php.net/ChangeLog-7.php
-https://www.php.net/downloads.php

 

[PASCON 2019 개최]
·하반기 최대 정보보안/개인정보보호 컨퍼런스 PASCON 2019
·7시간 보안교육 이수 및 2020년 대비 보안실무 교육
·공공,기업 개인정보보호 및 정보보안 실무자라면 누구나 무료 참석
-무료사전등록: 클릭

★정보보안 대표 미디어 데일리시큐!★