2020-10-24 18:20 (토)
OpenSSL 심각한 보안취약점 발견...정보유출 위험
상태바
OpenSSL 심각한 보안취약점 발견...정보유출 위험
  • 길민권
  • 승인 2014.04.10 15:49
이 기사를 공유합니다

허트블리드 취약점, 개인정보 및 웹서버 암호키도 유출 가능해
웹브라우저와 서버 간의 통신을 암호화하는 오픈소스 라이브러리인 ‘OpenSSL’에 심각한 취약점이 발견됐다. 즉각적인 업데이트가 필요한 상황이다.
 
취약점이 발견된 버전은 OpenSSL 1.0.1 ~ 1.0.1f 및 OpenSSL 1.0.2-beta, 1.0.2-beta1이며 취약점이 없는 버전은 OpenSSL 1.0.0 대 버전 및 OpenSSL 0.9.x 대 버전이다.
 
이 취약점은 허트블리드(HeartBleed)로 명명되고 있으며, 해당 취약점을 악용할 경우 웹서버로 전송된 개인정보, 비밀번호 등은 물론 웹서버의 암호키도 탈취될 수 있다.
 
공격자는 취약점이 발견된 OpenSSL 버전이 설치된 서버에서 인증 정보 등이 저장된 64Kbyte 크기의 메모리 데이터를 외부에서 아무런 제한 없이 탈취할 수 있다. 해당 취약점은 허트비트(Heartbeat)라는 SSL 확장 프로토콜을 구현하는 과정에서 발생했으며, 2012년 3월부터 OpenSSL 1.0.1 버전에 구현되었다.
 
해당 취약점을 해결하기 위해서는 OpenSSL 공식홈페이지(www.openssl.org)에 접속해 지난 4월 7일에 배포된 OpenSSL 1.0.1g 버전으로 업데이트를 해야 한다. OpenSSL은 주로 공개용 웹서버 프로그램인 아파치 또는 엔진엑스(Nginx)와 함께 사용되는 경우가 많아 이를 사용하는 경우 특히 OpenSSL의 버전을 확인하고 조치해야 한다.
 
업데이트가 어려운 경우는 ‘-DOPENSSL_NO_HEARTBEATS’ 옵션 설정 후 재컴파일해 heartbeat 비활성화해야 한다.
 
정현철 KISA 침해사고분석단장은 “이번 취약점을 악용하는 공격 코드가 공개되어 당분간 공격이 증가할 것으로 우려되며, OpenSSL을 사용하는 기업이나 기관은 중요 정보가 유출되는 것을 막기 위해 즉시 업데이트를 해야 한다”고 당부했다.
 
데일리시큐 길민권 기자 mkgil@dailysecu.com