2020-07-10 17:55 (금)
아래한글, 원격코드 실행 취약점 2건…패치필수!
상태바
아래한글, 원격코드 실행 취약점 2건…패치필수!
  • 길민권
  • 승인 2012.08.10 16:28
이 기사를 공유합니다

낮은 버전 아래한글 사용자 악성코드 감염 주의…패치적용 해야!
한글과컴퓨터사에서 개발한 워드프로세서인 ‘아래한글’에서 원격 코드실행 취약점 2종이 발견됐다. 공격자는 웹 게시, 스팸 메일, 메신저의 링크 등을 통해 특수하게 조작된 한글문서(HWP)파일을 사용자가 열어보도록 유도해 원격코드가 실행될 수 있는 취약점이 존재해 사용자들은 신속한 보안업데이트를 해야 안전하다.   
 
사용자가 특수하게 조작된 DLL파일과 동일한 디렉토리 경로에 존재하는 정상 HWP 문서파일을 열람할 경우, 원격코드가 실행될 수 있는 취약점이 존재한다.
 
낮은 버전의 아래한글 사용자는 악성코드 감염에 취약할 수 있으므로 해결방안에 따라 보안업데이트를 해야 한다.
 
영향 받는 소프트웨어는 한글 2002 5.7.9.3055 및 이전 버전, 한글 2004 6.0.5.773 및 이전 버전, 한글 2005 6.7.10.1074 및 이전 버전, 한글 2007 7.5.12.631 및 이전 버전, 한글 2010 8.5.8.1234 및 이전 버전 등이다.
 
취약점 패치를 위해서는 한글과컴퓨터 홈페이지를 방문해 보안업데이트 파일을 다운받아 설치하거나, 자동업데이트를 통해 한글 최신버전으로 업데이트해야 안전하다.
-참고사이트: www.hancom.co.kr/downLoad.downPU.do?mcd=001
-자동업데이트: 시작 → 모든 프로그램 → 한글과컴퓨터 → 한컴 자동 업데이트
 
이번 취약점 중 1종은 제4회 사이버공격 시나리오 공모전을 통해 박종섭씨가 발표한 내용이다.
 
데일리시큐 길민권 기자 mkgil@dailysecu.com