2024-06-16 18:30 (일)
RSA 인증 SDK에서 심각한 인증우회 취약점 2건 발견돼
상태바
RSA 인증 SDK에서 심각한 인증우회 취약점 2건 발견돼
  • 길민권 기자
  • 승인 2017.12.08 20:41
이 기사를 공유합니다

aaaa-5.jpg
RSA 인증 SDK에서 CVE-2017-14377, CVE-2017-14378 취약점이 발견됐다. 최신 버전으로 업데이트를 적용해야 안전할 수 있다.

CVE-2017-14377 취약점은 RSA 인증 프록시 for Web for Apache Web Serber의 인증우회 취약점이다.

RSA 인증프록시가 UDP 모드로 구성된 경우, 해당 취약점에 영향을 받지 않습니다. 하지만 만약 TCP 모드로 설정되어 있는 경우, 원격에서 인증받지 않은 공격자가 특별히 조작된 패킷을 이용해 인증오류 로직을 발생시켜 불법적으로 자산에 접근이 가능하게 된다. 사용자들은 각별한 주의가 요구된다.

또 CVE-2017-14378은 취약점은 RSA 인증프록시의 SDK for C(버전 8.5 및 8.6)에 존재하며, 해당 SDK를 사용하는 모든 시스템이 영향을 받는다.

RSA 인증 프록시 API/SDK버전 8.5/8.6 for C가 에러를 처리하는 과정에 취약점이 존재한다. TCP 비동기 모드를 사용할 때, 에러에 대해 잘못된 처리로 반환되는 코드를 애플리케이션에서 처리를 제대로 하지 못해 발생하는 인증우회취약점이다. 사용자들은 반드시 최신 버전으로 업데이트를 진행해야 한다.

★정보보안 대표 미디어 데일리시큐!★

■ 보안 사건사고 제보 하기

▷ 이메일 : mkgil@dailysecu.com

▷ 제보 내용 : 보안 관련 어떤 내용이든 제보를 기다립니다!

▷ 광고문의 : jywoo@dailysecu.com

★정보보안 대표 미디어 데일리시큐 / Dailysecu, Korea's leading security media!★