2024-07-25 02:50 (목)
Dnsmasq 7개 신규 보안취약점 공개…랜섬웨어 감염 등 피해 주의
상태바
Dnsmasq 7개 신규 보안취약점 공개…랜섬웨어 감염 등 피해 주의
  • 길민권 기자
  • 승인 2017.10.15 16:40
이 기사를 공유합니다

Dnsmasq 2.78 이전 버전 이용자들은 Dnsmasq 2.78 버전으로 업데이트 적용해야

dns.jpg
Dnsmasq 소프트웨어에서 발생하는 취약점을 해결한 보안 업데이트를 발표했다. 영향 받는 버전의 사용자는 랜섬웨어 감염, 서버 침해 등의 피해가 발생할 수 있기 때문에 해결방안에 따라 최신 버전으로 업데이트 해야 한다.

이번 7개 신규 보안취약점 내용은 다음과 같다.

△로컬 네트워크에서 익스플로잇될 수 있는 DNS Subsystem 원격 코드 실행 취약점 (CVE-2017-14491)

△IPv6 라우터의 알림 요청에서 원격 코드 실행을 가능하게 하는 힙 오버플로우 취약점(CVE-2017-14492)

△CVE-2017-14494 취약점과 함께 사용되었을 때 원격 코드 실행이 가능한 스택 오버플로우 취약점(CVE-2017-14493)

△Relay로 구성되었을 때 DHCPv6 요청을 처리하는 과정에서 발생하는 메모리 정보 노출 취약점(CVE-2017-14494)

△–add-mac, add-cpe-id 또는 —add-subnet 옵션이 설정된 dnsmasq에서 발생하는 서비스 거부 공격이 가능한 메모리 정보 노출 취약점(CVE-2017-14495)

△–add-mac, add-cpe-id 또는 —add-subnet 옵션이 설정된 dnsmasq의 add_pseudoheader 함수에서 발생하는 서비스 거부 공격이 가능한 정수 오버플로우 취약점(CVE-2017-14496)

△DNS의 패킷 크기가 설정된 크기보다 클 때 프로그램 실행이 종료되는 취약점(CVE-2017-13704)

영향을 받는 버전은 Dnsmasq 2.78 이전 버전 이용자들은 Dnsmasq 2.78 버전으로 업데이트를 적용해야 한다.

 

★정보보안 대표 미디어 데일리시큐!★


■ 보안 사건사고 제보 하기

▷ 이메일 : mkgil@dailysecu.com

▷ 제보 내용 : 보안 관련 어떤 내용이든 제보를 기다립니다!

▷ 광고문의 : jywoo@dailysecu.com

★정보보안 대표 미디어 데일리시큐 / Dailysecu, Korea's leading security media!★