2020-09-22 20:30 (화)
스카이프에서 원격코드 실행이 가능한 치명적 취약점 발견
상태바
스카이프에서 원격코드 실행이 가능한 치명적 취약점 발견
  • 페소아 기자
  • 승인 2017.06.28 17:47
이 기사를 공유합니다

원격 공격자가 시스템을 정지시키고 코드 실행할 수 있는 치명적인 결함

SK-1.jpg
마이크로소프트의 스카이프(Skype) 웹메시징 및 통화서비스에서 원격 공격자가 시스템을 정지시키고 코드를 실행할 수 있는 치명적인 결함이 발견되었다.

Vunerability Lab의 보안연구원 벤야민 쿤즈 메즈리(Benjamin Kunz Mejri)는 Skype 7.2, 7.35, 7.36에 존재하는 스택오버플로우 취약점(CVE-2017-9948)을 발견했다. 취약점의 심각도를 표시하는 CVSS 점수는 7.2로 공격자는 스택 버퍼 오버 플로우 취약점을 이용해 응용 프로그램을 원격으로 크래시하고 활성 프로세스 레지스터를 덮어써 악의적인 코드를 실행할 수 있다.

해당 취약점은 로컬시스템에서 복사요청시 스카이프가 MSFTEDIT.DLL 파일을 사용할 때 문제가 발생한다. Vunerability Lab은 제작된 이미지파일을 클립보드에서 스카이프 메시지 상자로 복사해 붙여넣는 것으로 테스트했으며, 이미지가 원격 및 로컬 시스템의 클립보드에서 호스팅으로 전송되었을 때, 스카이프에서 스택버퍼오버플로우가 일어나 익스플로잇 가능한 크래쉬가 발생했다. 피해자의 계정에서 상호작용없이 로컬 및 원격 공격자가 모두 악용가능하며, 공격을 위해서는 낮은 권한의 스카이프 계정만 필요할 뿐이다.

Vulnerability Lab은 "원격 세션 클립보드의 출력을 통한 이미지의 크기와 수에는 제한이 없다. 공격자는 특정 요청을 통해 활성화된 소프트웨어 프로세스의 EIP레지스터를 덮어쓸 수 있다"라고 설명했다. 그들은 개념증명코드(PoC) 역시 공개했다.

Vulnerability는 지난 5월 16일에 마이크로소프트 측에 버그를 통보했으며, 마이크로소프트는 6월 8일에 Skype 7.37.178버전으로 패치를 진행했고 6월 26일에 공개했다.

★정보보안 대표 미디어 데일리시큐!★