2020-01-22 12:30 (수)
공개 웹 게시판 알지보드, DB정보유출 주의!
상태바
공개 웹 게시판 알지보드, DB정보유출 주의!
  • 길민권
  • 승인 2011.07.01 20:20
이 기사를 공유합니다

알지보드, SQL인젝션 취약점 발견...DB정보유출 가능해
국내 PHP기반의 공개 웹 게시판인 알지보드에서 SQL Injection 취약점이 발견됐다. 취약한 버전을 사용하고 있을 경우, DB정보 유출 등의 피해를 입을 수 있기 때문에 웹 관리자의 적극적인 조치가 필요하다. 해당 취약점 정보가 해외에서 공유되고 있기 때문에 보다 적극적인 조치가 요구된다.
 
영향받는 소프트웨어는 알지보드 4.2.1 및 이전 버전들다.
 
KISA 인터넷침해대응센터는 “알지보드 4.2.1 및 이전버전 사용자는 4.2.1p1 버전으로 업데이트해야 하며 패치 작업 이전에 원본 파일은 백업을 해야 하고, 알지보드를 새로 설치하는 이용자는 반드시 보안패치가 적용된 최신버전(4.2.1p1)을 설치해야 한다”고 권고했다.
 
<용어해설>
-PHP: 동적인 웹사이트를 위한 서버 측 스크립트 언어
-SQL Injection: 웹 응용 프로그램에 강제로 SQL구문을 삽입하여 내부 데이터베이스 서버의 데이터를 유출 및 변조하고 관리자 인증을 우회할 수 있는 공격
-알지보드 : PHP언어로 작성된 홈페이지용 게시판 소프트웨어 또는 프레임 워크

 
<참고사이트>
v4.rgboard.com/rg4_board/view.php?&bbs_code=rgboard_pds&bd_num=1772
[데일리시큐=길민권 기자]