2020-07-04 02:30 (토)
리눅스 Ghost 버퍼오버플로우 취약점 주의
상태바
리눅스 Ghost 버퍼오버플로우 취약점 주의
  • 길민권
  • 승인 2015.01.29 04:38
이 기사를 공유합니다

임의코드 실행 가능 취약점…보안 업데이트 필수
미국 US-CERT는 리눅스 GNU C 라이브러리(glibc)에서 임의코드를 실행할 수 있는 취약점(CVE-2015-0235)이 발견되었다고 발표했다.
 
CVE-2015-0235는 해당 라이브러리의 gethostbyname( ) 함수 처리 과정에서 발생하는 버퍼오버플로우 취약점이다.
 
라이브러리에 존재하는 특정 함수(__nss_hostname_digits_dots( ))의 잘못된 메모리 사용으로 인해 오버플로우가 발생해 프로그램의 실행 흐름 변경이 가능하다.
 
__nss_hostname_digits_dots( ) 함수란 도메인 주소를 IP 주소로 변환할 때 사용하는 함수인 gethostbyname( )를 호출 시 내부적으로 호출되는 함수를 말한다.
 
영향을 받는 시스템은 glibc 2.2~2.17버전의 모든 리눅스 시스템이다.
 
취약한 버전의 라이브러리를 사용하는 시스템은 상위 버전으로 반드시 업데이트해야 한다. 특히 실행파일에 취약한 버전의 라이브러리를 포함해 컴파일 한 경우, 상위 버전의 라이브러리로 재컴파일 해 설치할 필요가 있다.
 
다음 참고사이트의 내용을 참조해 보안업데이트를 수행하면 된다.
-http://lists.centos.org/pipermail/centos/2015-January/149413.html
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776391
-https://access.redhat.com/articles/1332213
-http://www.ubuntu.com/usn/usn-2485-1/
 
<★정보보안 대표 미디어 데일리시큐!★>
 
데일리시큐 길민권 기자 mkgil@dailysecu.com