2019-10-14 19:31 (월)
공개 웹게시판 그누보드 SQL 인젝션 취약점 발견
상태바
공개 웹게시판 그누보드 SQL 인젝션 취약점 발견
  • 길민권
  • 승인 2011.08.11 16:56
이 기사를 공유합니다

취약한 버전 사용할 경우, DB정보 유출 등 피해 발생 우려
그누보드 4.34.09 및 이전버전 사용자는 4.34.10버전으로 교체
국내 PHP기반의 공개 웹 게시판인 그누보드에서 SQL Injection 취약점이 발견됐다. 취약한 버전을 사용하고 있을 경우, DB정보 유출 등의 피해를 입을 수 있으므로 웹 관리자의 적극적인 조치가 필요하다.
 
이번 취약점에 영향받는 소프트웨어는 그누보드 4.34.09 및 이전 버전이다.
 
KISA 인터넷침해대응센터는 “그누보드 4.34.09 및 이전버전 사용자는 4.34.10버전으로 업데이트해야하고 패치 작업 이전에 원본 파일은 백업이 필요하다. 또 그누보드를 새로 설치하는 이용자는 반드시 보안패치가 적용된 최신버전(4.34.10)을 설치해야 한다”고 경고했다.  
 
<용어 정리>
-PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어
-SQL Injection : 웹 응용 프로그램에 강제로 SQL구문을 삽입하여 내부 데이터베이스서버의      데이터를 유출 및 변조하고 관리자 인증을 우회할 수 있는 공격
-그누보드 : PHP언어로 작성된 홈페이지용 게시판 소프트웨어 또는 프레임 워크
 
<참고사이트>
sir.co.kr/bbs/board.php?bo_table=g4_pds&wr_id=6476
[데일리시큐=길민권 기자]