2021-03-07 01:35 (일)
워드프레스 사진갤러리 취약점 주의…최신 버전 사용해야
상태바
워드프레스 사진갤러리 취약점 주의…최신 버전 사용해야
  • 길민권 기자
  • 승인 2021.02.14 00:30
이 기사를 공유합니다

자료 이미지. 기사내용과 무관.
자료 이미지. 기사내용과 무관.

넥스트젠 갤러리 플러그인 개발팀은 사이버공격에 악용될 수 있는 두 가지 심각한 CSRF 취약점을 해결했다고 밝혔다.

넥스트젠 갤러리는 2007년부터 많은 유저들이 사용해 온 가장 인기있는 워드프레스(WordPress) 사진 갤러리 플러그인 중 하나다. 현재 80만개 사이트에 설치된 프로그램이다.

해당 플러그인 개발자는 이번에 두 가지 중요한 CSRF(Cross-site request forgery) 취약점(CVE-2020-35942)을 수정했으며, 이 취약점을 악용하면 사이트 탈취, 악성 리디렉션, 스팸 주입, 피싱 및 원격 코드 실행 등 다양한 악성 활동이 가능해 보안위협에 노출될 우려가 크다.

보안전문가들은 웹 사이트에서 원격 코드 실행을 달성하면 공격자가 취약한 버전의 플러그인을 실행하는 사이트를 장악 할 수 있다고 경고하고 있다.

공격자는 워드프레스 관리자가 특수 제작 된 링크나 첨부 파일을 클릭해 악의적인 작업을 수행하도록 유인해 사이트를 점령할 수 있다.

또 로그인 한 관리자가 악성 삽입 스크립트를 실행하는 페이지를 방문하는 경우 XSS를 사용해 사이트를 장악 할 수도 있는 상황이다.

★정보보안 대표 미디어 데일리시큐!★