check 3d gpu
바로가기
메뉴로 이동
본문으로 이동

워드프레스 5.0.0 원격 코드 실행 취약점 6년만에 발견돼

hsk 기자 mkgil@dailysecu.com 2019년 02월 21일 목요일

binary-1607161_640.jpg
RIPS Technologies GmbH의 보안 전문가들이 워드프레스5.0.3이전 버전들의 심각한 원격 코드 실행 취약점을 공개했다. 이는 무려 6년간 밝혀지지 않았던 취약점이다.

전문가들은 워드프레스 설치에서 적어도 작성자 이상의 권한을 가진 계정에 접근해 기본 서버에서 임의 PHP 코드를 실행하는 누군가가 해당 결함을 악용할 수 있음을 발견했다. 이 결함은 워드프레스 코어에서의 원격 코드 실행과 완전한 원격 탈취로 이어지는 Path Traversal및 로컬 파일 Inclusion 취약점의 체인이다.

전문가들은 해당 문제를 워드프레스 개발자에게 보고했지만 아직 패치되지 않았다. 연구원들이 발표한 분석 글은 “대상 워드프레스 사이트에서 작성자 이상계정에 접근 권한을 얻은 공격자는 기본 서버에서 임의 PHP 코드를 실행할 수 있고, 이로 인해 완전한 원격 탈취가 가능하다”라고 설명한다.

또한 “우리는 워드프레스 보안팀에게 코어의 다른 취약점 관련 세부 정보를 보냈다. 이 취약점은 공격자에게 현재 패치되지 않은 모든 워드프레스 사이트에 대한 접근 권한을 제공할 수 있다”고 덧붙였다.

워드프레스 다운로드 페이지에 따르면 온라인상의 웹 사이트 중 33%가 취약한 소프트웨어를 사용한다. 공격은 워드프레스 이미지 관리 시스템이 크기, 작성자, 업로드된 이미지의 다른 메타 정보 등을 저장하는 포스트 메타 항목을 처리하는 방식에 따라 달라진다.

전문가들은 워드프레스 설치에서 최소한 작성자 권한 이상을 가진 공격자가 이미지와 관련된 항목을 수정하여 경로 탐색 취약점을 유발할 수 있다는 사실을 발견했다.

이들은 “해당 아이디어는 _wp_attached_file을 evil.jpg?shell.php로 설정하는 것이다. 이를 통해 https://targetserver.com/wp-content/uploads/evil.jpg?shell.php에HTTP요청이 전송된다. ‘?’가 이 컨텍스트에서 무시되기 때문에 이 요청은 유효한 이미지 파일을 반환한다. 결과 파일 이름은 evil.jpg?shell.php이다. 그러나 evil.jpg?/../../evil.jpg와 같은 페이로드를 사용해 어떠한 디렉토리에든 결과 이미지를 심는 것이 가능하다.”라고 설명했다.

Path Traversal 취약점을 로컬 파일 Inclusion 결함과 연결시킴으로써 공격자는 타깃 서버에서 임의 코드를 실행할 수 있다.

워드프레스 버전5.0.1과4.9.9에서 보안 조치를 통해 승인되지 않은 사용자가 임의의 Post Meta 항목을 설정할 수 없기 때문에 취약점 익스플로잇을 방지할 수 있다.

전문가들은 아직 최신 워드프레스에서도 Path Traversal 취약점이 패치되지 않았고, Post Meta 항목을 부정확하게 처리하는 써드파티플러그인을 통해 익스플로잇이 가능할 수도 있다고 지적했다. 또한 타깃 워드프레스 사이트에 대한 특정 인증이 필요하기 때문에 취약점 보고 후 4개월이 지나면 취약점들을 공개하기로 결정했다고 언급했다.

워드프레스는 다음번 배포 시 취약점을 해결할 예정이다.

★정보보안 대표 미디어 데일리시큐!★


<저작권자 © 데일리시큐, 무단 전재 및 재배포 금지>
목록